blog.up-link.ro
17Nov/100

How To Install QEMU under FreeBSD 8.1 as Host OS

QEMU is a processor emulator that relies on dynamic binary translation to achieve a reasonable speed while being easy to port on new host CPU architectures.
When used as a machine emulator, QEMU can run Operating Systems and programs made for one machine on a different machine. By using dynamic translation, it achieves very good performance.
When used as a virtualizer, QEMU achieves near native performances by executing the guest code directly on the host CPU.

1. Install QEMU

To install QEMU under FreeBSD, enter:

make install clean -C /usr/ports/emulators/qemu

Install QEMU with options showed in the following image:

Edit /boot/loader.conf to load required kernel modules at start up.
Add the following lines to /boot/loader.conf:
aio_load="YES"
kqemu_load="YES"

To load the kernel modules, enter:

kldload aio
kldload kqemu

2. Create QEMU Operating System as Guest

To create QEMU image for the new operating system, enter:

qemu-img create -f qcow2 ~/qemu/newos.img 8G

To install the new operating system, enter:

qemu -boot d -hda ~/qemu/newos.img -m 128 -cdrom ~/qemu/osimage.iso -localtime

Note: If you have any problems while installing the guest operating system then unload kqemu kernel module and install again, then after install, load the kqemu module again:

kldunload kqemu
qemu -boot d -hda ~/qemu/newos.img -m 256 -cdrom ~/qemu/osimage.iso -localtime
kldload kqemu

3. QEMU Usage

Typical usage of operating system under QEMU:

qemu -hda ~/qemu/newos.img -m 256 -localtime

Typical usage of operating system under QEMU in Snapshot mode:

qemu -hda ~/qemu/newos.img -m 256 -localtime -snapshot

Note: To commit made changes hit left_CTRL+left_ALT+2 and type commit.

To switch focus between QEMU mouse focus and X11 mouse focus use left_CTRL+left_ALT

To ensure that You use kqemu kernel module in user mode hit left_CTRL+left_ALT+2 and type info kqemu, if everything is fine you will see:
kqemu support: enabled for user code

To switch between QEMU console and QEMU opearating system emulation use left_CTRL+left_ALT+2 to go to console and left_CTRL+left_ALT+1 to back to emulation.

To enable network on emulated operating system, use DHCP configuration inside the emulated operating system to get automatic IP address 10.x.x.x.

After you quit the emulated operating system, use this command to launch again your emulated operating system:

qemu -hda ~/qemu/newos.img -m 256 -localtime

To have sound in the QEMU operating system, you just need to launch QEMU with -soundhw sb16 or -soundhw es1370 to emulate Sound Blaster 16, or Sound Blaster 128. You can also enable standart annoying BEEP with -soundhw pcspk. You can also enable all three of them:

qemu -hda ~/qemu/newos.img -m 256 -localtime -soundhw es1370,pcspk,sb16

Type qemu --help and qemu-img --help for more options.

Print This Post Print This Post
Comments (0) Trackbacks (0)

No comments yet.


Leave a comment


*

No trackbacks yet.